What’s Vulnerable › Vulnerabilities
CVE-2026-26032: Apache Ivy: PackagerResolver path traversal vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-10-24
- Weakness: CWE-22
Description
The PackagerResolver of Apache Ivy is able to download online artifacts and to (re)package them in a format defined by a packager.xml file. This repackaging is done by an Ant script, which is stored in a subdirectory of the configured "buildRoot" directory. This subdirectory is calculated based on modules coordinates, like the organisation, name or version. If one of the coordinates contains "../" sequences - which are valid characters for Ivy coordinates in general- it is possible to break out of the configured "buildRoot" directory where other files can be overwritten. In order to exploit this vulnerability an attacker needs to have access to a packager repository and add or modify the coordinates in ivy.xml files to have such "../" sequences. Users of Apache Ivy 2.0.0 to 2.5.3 (inclusive) should upgrade to Ivy 2.6.0.
Affected products
- Apache Software Foundation Apache Ivy: from 2.0.0 before 2.6.0 — fixed in 2.6.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Ivy 2.6.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/4d9dzrlnoplvywnyj9x6w84kxg7n3jyq
- http://www.openwall.com/lists/oss-security/2026/07/15/5
Get alerted when CVE-2026-26032 or the next vulnerability affects your stack