What’s Vulnerable › Vulnerabilities
CVE-2026-26045: Moodle: moodle: improper validation in file restore functionality leading to remote code execution
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-21 · updated 2026-06-17
- Weakness: CWE-94
Description
A flaw was identified in Moodle’s backup restore functionality where specially crafted backup files were not properly validated during processing. If a malicious backup file is restored, it could lead to unintended execution of server-side code. Since restore capabilities are typically available to privileged users, exploitation requires authenticated access. Successful exploitation could result in full compromise of the Moodle server.
Affected products
- Moodle: before 4.5.9; from 5.0.0 before 5.0.5; from 5.1.0 before 5.1.2 — fixed in 4.5.9, 5.0.5, 5.1.2
How to fix
Upgrade to a fixed version: Moodle 4.5.9, 5.0.5, 5.1.2. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2026-26045
- https://bugzilla.redhat.com/show_bug.cgi?id=2440901
Get alerted when CVE-2026-26045 or the next vulnerability affects your stack