What’s Vulnerable › Vulnerabilities
CVE-2026-26059: ChurchCRM has Stored Cross-Site Scripting (XSS) in GroupEditor.php
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-19 · updated 2026-06-17
- Weakness: CWE-79
Description
ChurchCRM is an open-source church management system. In versions prior to 6.8.2, it was possible for an authenticated user with permission to edit groups to store a JavaScript payload that would execute when the group was viewed in the Group View. Version 6.8.2 fixes this issue.
Affected products
- ChurchCRM CRM: before 6.8.2 — fixed in 6.8.2
How to fix
Upgrade to a fixed version: ChurchCRM CRM 6.8.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-26059 or the next vulnerability affects your stack