What’s Vulnerable › Vulnerabilities
CVE-2026-2611: Improper Origin Validation in mlflow/mlflow
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-19 · updated 2026-10-14
- Weakness: CWE-346
Description
In MLflow version 3.9.0, the MLflow Assistant feature introduced improper origin validation in its /ajax-api endpoints. This vulnerability allows a remote attacker to exploit cross-origin requests from a malicious webpage to interact with the MLflow Assistant running on a victim's local machine. By bypassing the loopback-only restriction, the attacker can modify the Assistant's configuration to enable full access, which in turn allows the execution of arbitrary commands via the Claude Code sub-agent. This issue is resolved in version 3.10.0.
Affected products
- mlflow/mlflow: from 3.9.0 before 3.10.0 — fixed in 3.10.0
How to fix
Upgrade to a fixed version: mlflow/mlflow 3.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/mlflow/mlflow/commit/8f9c8a53af90842944101eb8b7d60706822c81bc
- https://huntr.com/bounties/8462addd-b464-4a84-b6a2-5529604e6e5a
- https://access.redhat.com/security/cve/CVE-2026-2611
- https://bugzilla.redhat.com/show_bug.cgi?id=2479797
- https://huntr.com/bounties/8462addd-b464-4a84-b6a2-5529604e6e5a
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-2611.json
Get alerted when CVE-2026-2611 or the next vulnerability affects your stack