What’s Vulnerable › Vulnerabilities
CVE-2026-26115: SQL Server Elevation of Privilege Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-06-19
- Weakness: CWE-1287
Description
Improper validation of specified type of input in SQL Server allows an authorized attacker to elevate privileges over a network.
Affected products
- Microsoft Sql Server 2016: from 13.0.6300.2 before 13.0.6480.4; from 13.0.7000.253 before 13.0.7075.5 — fixed in 13.0.6480.4, 13.0.7075.5
- Microsoft Sql Server 2017: from 14.0.1000.169 before 14.0.2100.4; from 14.0.3006.16 before 14.0.3520.4 — fixed in 14.0.2100.4, 14.0.3520.4
- Microsoft Sql Server 2019: from 15.0.2000.5 before 15.0.2160.4; from 15.0.4003.23 before 15.0.4460.4 — fixed in 15.0.2160.4, 15.0.4460.4
- Microsoft Sql Server 2022: from 16.0.1000.6 before 16.0.1170.5; from 16.0.4003.1 before 16.0.4240.4 — fixed in 16.0.1170.5, 16.0.4240.4
- Microsoft Sql Server 2025: from 17.0.1000.7 before 17.0.1050.2; from 17.0.4006.2 before 17.0.4020.2 — fixed in 17.0.1050.2, 17.0.4020.2
- Microsoft SQL Server 2016 Service Pack 3 Azure Connect Feature Pack: from 13.0.0 before 13.0.7075.5 — fixed in 13.0.7075.5
- Microsoft SQL Server 2016 Service Pack 3 (GDR): from 13.0.0 before 13.0.6480.4 — fixed in 13.0.6480.4
- Microsoft SQL Server 2017 (CU 31): from 14.0.0 before 14.0.3520.4 — fixed in 14.0.3520.4
- Microsoft SQL Server 2017 (GDR): from 14.0.0 before 14.0.2100.4 — fixed in 14.0.2100.4
- Microsoft SQL Server 2019 (CU 32): from 15.0.0.0 before 15.0.4460.4 — fixed in 15.0.4460.4
- Microsoft SQL Server 2019 (GDR): from 15.0.0 before 15.0.2160.4 — fixed in 15.0.2160.4
- Microsoft SQL Server 2022 for x64-based Systems (CU 23): from 16.0.0.0 before 16.0.4240.4 — fixed in 16.0.4240.4
- Microsoft SQL Server 2022 (GDR): from 16.0.0 before 16.0.1170.5 — fixed in 16.0.1170.5
- Microsoft SQL Server 2025 (CU 2): from 17.0.0.0 before 17.0.4020.2 — fixed in 17.0.4020.2
- Microsoft SQL Server 2025 for x64-based Systems (GDR): from 17.0.1050.2 before 17.0.1105.2 — fixed in 17.0.1105.2
How to fix
Upgrade to a fixed version: Microsoft Sql Server 2016 13.0.6480.4, 13.0.7075.5; Microsoft Sql Server 2017 14.0.2100.4, 14.0.3520.4; Microsoft Sql Server 2019 15.0.2160.4, 15.0.4460.4; Microsoft Sql Server 2022 16.0.1170.5, 16.0.4240.4; Microsoft Sql Server 2025 17.0.1050.2, 17.0.4020.2; Microsoft SQL Server 2016 Service Pack 3 Azure Connect Feature Pack 13.0.7075.5; Microsoft SQL Server 2016 Service Pack 3 (GDR) 13.0.6480.4; Microsoft SQL Server 2017 (CU 31) 14.0.3520.4; Microsoft SQL Server 2017 (GDR) 14.0.2100.4; Microsoft SQL Server 2019 (CU 32) 15.0.4460.4; Microsoft SQL Server 2019 (GDR) 15.0.2160.4; Microsoft SQL Server 2022 for x64-based Systems (CU 23) 16.0.4240.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-26115 or the next vulnerability affects your stack