What’s Vulnerable › Vulnerabilities
CVE-2026-26188: Solspace Freeform plugin affected by Stored Cross-Site Scripting (XSS) in Freeform Craft Plugin CP UI (builder/integrations)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-12 · updated 2026-06-17
- Weakness: CWE-79
Description
Solspace Freeform plugin for Craft CMS 5.x is a super flexible form-building tool. An authenticated, low-privilege user (able to create/edit forms) can inject arbitrary HTML/JS into the Craft Control Panel (CP) builder and integrations views. User-controlled form labels and integration metadata are rendered with dangerouslySetInnerHTML without sanitization, leading to stored XSS that executes when any admin views the builder/integration screens. This vulnerability is fixed in 5.14.7.
Affected products
- solspace craft-freeform: from 5.0.0 before 5.14.7 — fixed in 5.14.7
How to fix
Upgrade to a fixed version: solspace craft-freeform 5.14.7. Check the vendor advisory for mitigations.
References
- https://github.com/solspace/craft-freeform/commit/b9adad6cdf1eba5400aae8b1ae39bd7d4d33af5e
- https://github.com/solspace/craft-freeform/releases/tag/v5.14.7
- https://github.com/solspace/craft-freeform/security/advisories/GHSA-jp3q-wwp3-pwv9
Get alerted when CVE-2026-26188 or the next vulnerability affects your stack