What’s Vulnerable › Vulnerabilities

CVE-2026-2619: Incorrect Authorization in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 18.6 before 18.8.9, 18.9 before 18.9.5, and 18.10 before 18.10.3 that under certain circumstances could have allowed an authenticated user with auditor privileges to modify vulnerability flag data in private projects due to incorrect authorization.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.10.3, 18.8.9, 18.9.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-2619 or the next vulnerability affects your stack