What’s Vulnerable › Vulnerabilities
CVE-2026-26191: Fleet vulnerable to OS command injection in software packages
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-14 · updated 2026-10-26
- Weakness: CWE-78
Description
Fleet is open source device management software. Prior to version 4.81.0, a vulnerability in Fleet's software installer pipeline could allow a crafted software package to execute arbitrary commands as root (macOS/Linux) or SYSTEM (Windows) on managed endpoints when an uninstall is triggered. When a software package (.pkg, .deb, .rpm, .exe, or .msi) is uploaded to Fleet, metadata is extracted from the package binary and used to generate uninstall scripts. In affected versions, this metadata is not properly sanitized before being included in the generated scripts. A specially crafted package containing malicious values in its metadata fields could result in unintended command execution when the uninstall script runs on managed endpoints. Version 4.81.0 contains a patch. If an immediate upgrade is not possible, administrators should avoid uploading software packages obtained from untrusted or unverified sources. Additionally, administrators can manually inspect and edit auto-generated uninstall scripts before deployment.
Affected products
- fleetdm fleet: before 4.81.0 — fixed in 4.81.0
How to fix
Upgrade to a fixed version: fleetdm fleet 4.81.0. Check the vendor advisory for mitigations.
References
- https://github.com/fleetdm/fleet/releases/tag/fleet-v4.81.1
- https://github.com/fleetdm/fleet/security/advisories/GHSA-9vcr-g537-3w5v
Get alerted when CVE-2026-26191 or the next vulnerability affects your stack