What’s Vulnerable › Vulnerabilities
CVE-2026-26200: HDF5 Affected by H5T__conv_struct_opt Heap Buffer Overflow
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-19 · updated 2026-07-15
- Weakness: CWE-122
Description
HDF5 is software for managing data. Prior to version 1.14.4-2, an attacker who can control an `h5` file parsed by HDF5 can trigger a write-based heap buffer overflow condition. This can lead to a denial-of-service condition, and potentially further issues such as remote code execution depending on the practical exploitability of the heap overflow against modern operating systems. Real-world exploitability of this issue in terms of remote-code execution is currently unknown. Version 1.14.4-2 fixes the issue.
Affected products
- HDF5: before 1.14.4.2 — fixed in 1.14.4.2
How to fix
Upgrade to a fixed version: HDF5 1.14.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/HDFGroup/hdf5/security/advisories/GHSA-5p2m-j456-9mr2
- https://access.redhat.com/security/cve/CVE-2026-26200
- https://bugzilla.redhat.com/show_bug.cgi?id=2441088
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-26200.json
Get alerted when CVE-2026-26200 or the next vulnerability affects your stack