What’s Vulnerable › Vulnerabilities
CVE-2026-26203: PJSIP's pjmedia-video has use-after-free in H264 packetizer when packetizing fragmented NAL
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-19 · updated 2026-06-17
- Weakness: CWE-416
Description
PJSIP is a free and open source multimedia communication library. Versions prior to 2.17 have a critical heap buffer underflow vulnerability in PJSIP's H.264 packetizer. The bug occurs when processing malformed H.264 bitstreams without NAL unit start codes, where the packetizer performs unchecked pointer arithmetic that can read from memory located before the allocated buffer. Version 2.17 contains a patch for the issue.
Affected products
- Pjsip: before 2.17 — fixed in 2.17
How to fix
Upgrade to a fixed version: Pjsip 2.17. Check the vendor advisory for mitigations.
References
- https://github.com/pjsip/pjproject/commit/5aee54f09d4f91538d55279d7316591b28fded6c
- https://github.com/pjsip/pjproject/security/advisories/GHSA-p965-mf7j-gwv8
Get alerted when CVE-2026-26203 or the next vulnerability affects your stack