What’s Vulnerable › Vulnerabilities
CVE-2026-26207: DIscourse's discourse-policy plugin lacks post access check
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-26 · updated 2026-06-17
- Weakness: CWE-862
Description
Discourse is an open source discussion platform. Prior to versions 2025.12.2, 2026.1.1, and 2026.2.0, `discourse-policy` plugin allows any authenticated user to interact with policies on posts they do not have permission to view. The `PolicyController` loads posts by ID without verifying the current user's access, enabling policy group members to accept/unaccept policies on posts in private categories or PMs they cannot see and any authenticated user to enumerate which post IDs have policies attached via differentiated error responses (information disclosure). The issue is patched in versions 2025.12.2, 2026.1.1, and 2026.2.0 by adding a `guardian.can_see?(@post)` check in the `set_post` before_action, ensuring post visibility is verified before any policy action is processed. As a workaround, disabling the discourse-policy plugin (`policy_enabled = false`) eliminates the vulnerability. There is no other workaround without upgrading.
Affected products
- discourse: before 2025.12.0; from 2026.1.0 before 2026.1.1; 2026.2.0 — fixed in 2025.12.0, 2026.1.1
How to fix
Upgrade to a fixed version: discourse 2025.12.0, 2026.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-26207 or the next vulnerability affects your stack