What’s Vulnerable › Vulnerabilities

CVE-2026-26233: Denial of Service via HTTP/2 single packet attack on login endpoint

Description

Mattermost versions 11.4.x <= 11.4.0, 11.3.x <= 11.3.1, 11.2.x <= 11.2.3, 10.11.x <= 10.11.11 fail to rate limit login requests which allows unauthenticated remote attackers to cause denial of service (server crash and restart) via HTTP/2 single packet attack with 100+ parallel login requests.. Mattermost Advisory ID: MMSA-2025-00566

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.12, 11.2.4, 11.3.2, 11.4.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-26233 or the next vulnerability affects your stack