What’s Vulnerable › Vulnerabilities
CVE-2026-26268: Cursor sandbox escape via Git hooks
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-13 · updated 2026-06-17
- Weakness: CWE-862
Description
Cursor is a code editor built for programming with AI. Sandbox escape via writing .git configuration was possible in versions prior to 2.5. A malicious agent (ie prompt injection) could write to improperly protected .git settings, including git hooks, which may cause out-of-sandbox RCE next time they are triggered. No user interaction was required as Git executes these commands automatically. Fixed in version 2.5.
Affected products
- cursor: before 2.5 — fixed in 2.5
How to fix
Upgrade to a fixed version: cursor 2.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-26268 or the next vulnerability affects your stack