What’s Vulnerable › Vulnerabilities
CVE-2026-26323: OpenClaw has a command injection in maintainer clawtributors updater
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-19 · updated 2026-06-17
- Weakness: CWE-78
Description
OpenClaw is a personal AI assistant. Versions 2026.1.8 through 2026.2.13 have a command injection in the maintainer/dev script `scripts/update-clawtributors.ts`. The issue affects contributors/maintainers (or CI) who run `bun scripts/update-clawtributors.ts` in a source checkout that contains a malicious commit author email (e.g. crafted `@users[.]noreply[.]github[.]com` values). Normal CLI usage is not affected (`npm i -g openclaw`): this script is not part of the shipped CLI and is not executed during routine operation. The script derived a GitHub login from `git log` author metadata and interpolated it into a shell command (via `execSync`). A malicious commit record could inject shell metacharacters and execute arbitrary commands when the script is run. Version 2026.2.14 contains a patch.
Affected products
- OpenClaw: from 2026.1.8 before 2026.2.14 — fixed in 2026.2.14
How to fix
Upgrade to a fixed version: OpenClaw 2026.2.14. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/a429380e337152746031d290432a4b93aa553d55
- https://github.com/openclaw/openclaw/releases/tag/v2026.2.14
- https://github.com/openclaw/openclaw/security/advisories/GHSA-m7x8-2w3w-pr42
Get alerted when CVE-2026-26323 or the next vulnerability affects your stack