What’s Vulnerable › Vulnerabilities
CVE-2026-26354
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-22 · updated 2026-10-26
- Weakness: CWE-121
Description
Dell PowerProtect Data Domain with Domain Operating System (DD OS) of Feature Release versions 7.7.1.0 through 8.6, LTS2025 release version 8.3.1.0 through 8.3.1.10, LTS2024 release versions 7.13.1.0 through 7.13.1.60, contain a stack-based Buffer Overflow vulnerability. An unauthenticated attacker with remote access could potentially exploit this vulnerability, leading to arbitrary command execution.
Affected products
- Dell PowerProtect Data Domain: from 7.7.1.0 before 7.13.1.60; from 7.14.0.0 before 8.3.1.20; from 8.4.0.0 before 8.6.1.10 — fixed in 7.13.1.60, 8.3.1.20, 8.6.1.10
- Dell Powerprotect Dp Series Appliance: before 2.7.9 — fixed in 2.7.9
How to fix
Upgrade to a fixed version: Dell PowerProtect Data Domain 7.13.1.60, 8.3.1.20, 8.6.1.10; Dell Powerprotect Dp Series Appliance 2.7.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-26354 or the next vulnerability affects your stack