What’s Vulnerable › Vulnerabilities
CVE-2026-2645: Acceptance of CertificateVerify Message before ClientKeyExchange in TLS 1.2
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-19 · updated 2026-06-17
- Weakness: CWE-358
Description
In wolfSSL 5.8.2 and earlier, a logic flaw existed in the TLS 1.2 server state machine implementation. The server could incorrectly accept the CertificateVerify message before the ClientKeyExchange message had been received. This issue affects wolfSSL before 5.8.4 (wolfSSL 5.8.2 and earlier is vulnerable, 5.8.4 is not vulnerable). In 5.8.4 wolfSSL would detect the issue later in the handshake. 5.9.0 was further hardened to catch the issue earlier in the handshake.
Affected products
- wolfSSL: before 5.8.4 — fixed in 5.8.4
How to fix
Upgrade to a fixed version: wolfSSL 5.8.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-2645 or the next vulnerability affects your stack