What’s Vulnerable › Vulnerabilities
CVE-2026-2646: Heap buffer overflow in session parsing with wolfSSL_d2i_SSL_SESSION() function
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-19 · updated 2026-06-17
- Weakness: CWE-122
Description
A heap-buffer-overflow vulnerability exists in wolfSSL's wolfSSL_d2i_SSL_SESSION() function. When deserializing session data with SESSION_CERTS enabled, certificate and session id lengths are read from an untrusted input without bounds validation, allowing an attacker to overflow fixed-size buffers and corrupt heap memory. A maliciously crafted session would need to be loaded from an external source to trigger this vulnerability. Internal sessions were not vulnerable.
Affected products
- wolfSSL: before 5.9.0 — fixed in 5.9.0
How to fix
Upgrade to a fixed version: wolfSSL 5.9.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-2646 or the next vulnerability affects your stack