What’s Vulnerable › Vulnerabilities
CVE-2026-26514
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-04 · updated 2026-06-17
- Weakness: CWE-88
Description
An Argument Injection vulnerability exists in bird-lg-go before commit 6187a4e. The traceroute module uses shlex.Split to parse user input without validation, allowing remote attackers to inject arbitrary flags (e.g., -w, -q) via the q parameter. This can be exploited to cause a Denial of Service (DoS) by exhausting system resources.
Affected products
- xddxdd bird-lg-go: before 1.4.1 — fixed in 1.4.1
How to fix
Upgrade to a fixed version: xddxdd bird-lg-go 1.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/xddxdd/bird-lg-go/commit/6187a4e3afce6d8c29568f8c72ca497d1f5a2b56
- https://github.com/xddxdd/bird-lg-go/issues/136
Get alerted when CVE-2026-26514 or the next vulnerability affects your stack