What’s Vulnerable › Vulnerabilities
CVE-2026-2674: Out-of-bounds Write vulnerability in RTI Connext Professional (Queueing Service,Core Libraries,Persistence Service) allows Overflow Buffers.
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-17 · updated 2026-10-26
- Weakness: CWE-787
Description
Out-of-bounds Write vulnerability in RTI Connext Professional (Queueing Service,Core Libraries,Persistence Service) allows Overflow Buffers. This issue affects Connext Professional: from 7.4.0 before 7.7.0, from 7.0.0 before 7.3.1.3, from 6.1.0 before 6.1.*.
Affected products
- RTI Connext Professional: from 6.1.0 before 7.7.0 — fixed in 7.7.0
How to fix
Upgrade to a fixed version: RTI Connext Professional 7.7.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-2674 or the next vulnerability affects your stack