What’s Vulnerable › Vulnerabilities
CVE-2026-2687: Reading progressbar < 1.3.1 - Admin+ Stored XSS
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The Reading progressbar WordPress plugin before 1.3.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Reading progressbar: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: Reading progressbar 1.3.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-2687 or the next vulnerability affects your stack