What’s Vulnerable › Vulnerabilities

CVE-2026-26929: Apache Airflow: Wildcard DagVersion Listing Bypasses Per‑DAG RBAC and Leaks Metadata

Description

Apache Airflow versions 3.0.0 through 3.1.7 FastAPI DagVersion listing API does not apply per-DAG authorization filtering when the request is made with dag_id set to "~" (wildcard for all DAGs). As a result, version metadata of DAGs that the requester is not authorized to access is returned. Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Airflow 3.1.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-26929 or the next vulnerability affects your stack