What’s Vulnerable › Vulnerabilities
CVE-2026-26932: Improper Validation of Array Index in Packetbeat Leading to Denial of Service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-26 · updated 2026-06-17
- Weakness: CWE-129
Description
Improper Validation of Array Index (CWE-129) in the PostgreSQL protocol parser in Packetbeat can lead Denial of Service via Input Data Manipulation (CAPEC-153). An attacker can send a specially crafted packet causing a Go runtime panic that terminates the Packetbeat process. This vulnerability requires the pgsql protocol to be explicitly enabled and configured to monitor traffic on the targeted port.
Affected products
- Elastic Packetbeat: from 8.0.0 before 8.19.11; from 9.0.0 before 9.2.5 — fixed in 8.19.11, 9.2.5
How to fix
Upgrade to a fixed version: Elastic Packetbeat 8.19.11, 9.2.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-26932 or the next vulnerability affects your stack