What’s Vulnerable › Vulnerabilities
CVE-2026-26933: Improper Validation of Array Index in Packetbeat Leading to Denial of Service
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-19 · updated 2026-06-17
- Weakness: CWE-129
Description
Improper Validation of Array Index (CWE-129) in multiple protocol parser components in Packetbeat can lead Denial of Service via Input Data Manipulation (CAPEC-153). An attacker with the ability to send specially crafted, malformed network packets to a monitored network interface can trigger out-of-bounds read operations, resulting in application crashes or resource exhaustion. This requires the attacker to be positioned on the same network segment as the Packetbeat deployment or to control traffic routed to monitored interfaces.
Affected products
- Elastic Packetbeat: from 8.0.0 before 8.19.11; from 9.0.0 before 9.2.5 — fixed in 8.19.11, 9.2.5
How to fix
Upgrade to a fixed version: Elastic Packetbeat 8.19.11, 9.2.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-26933 or the next vulnerability affects your stack