What’s Vulnerable › Vulnerabilities
CVE-2026-2695: Lack of Server-side validation in Instruction Input in TeamViewer DEX Platform (On-Premises)
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-13 · updated 2026-10-26
- Weakness: CWE-20
Description
A command injection vulnerability was discovered in TeamViewer DEX Platform On-Premises (former 1E DEX Platform On-Premises) prior to version 9.2. Improper input validation allows authenticated users with at least questioner privileges to inject commands in specific instructions. Exploitation could lead to execution of elevated commands on devices connected to the platform.
Affected products
- TeamViewer DEX (On-Premises): before 9.2 — fixed in 9.2
How to fix
Upgrade to a fixed version: TeamViewer DEX (On-Premises) 9.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-2695 or the next vulnerability affects your stack