What’s Vulnerable › Vulnerabilities
CVE-2026-26967: PJSIP has a Heap-based Buffer Overflow vulnerability in its H.264 unpacketizer
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-20 · updated 2026-06-17
- Weakness: CWE-122
Description
PJSIP is a free and open source multimedia communication library written in C. In versions 2.16 and below, there is a critical Heap-based Buffer Overflow vulnerability in PJSIP's H.264 unpacketizer. The bug occurs when processing malformed SRTP packets, where the unpacketizer reads a 2-byte NAL unit size field without validating that both bytes are within the payload buffer bounds. The vulnerability affects applications that receive video using H.264. A patch is available at https://github.com/pjsip/pjproject/commit/f821c214e52b11bae11e4cd3c7f0864538fb5491.
Affected products
- Pjsip: before 2.17 — fixed in 2.17
How to fix
Upgrade to a fixed version: Pjsip 2.17. Check the vendor advisory for mitigations.
References
- https://github.com/pjsip/pjproject/commit/f821c214e52b11bae11e4cd3c7f0864538fb5491
- https://github.com/pjsip/pjproject/security/advisories/GHSA-x2hc-6969-g8v6
Get alerted when CVE-2026-26967 or the next vulnerability affects your stack