What’s Vulnerable › Vulnerabilities
CVE-2026-26974: Sylde has Improper Control of Generation of Code
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-20 · updated 2026-06-17
- Weakness: CWE-829
Description
Slyde is a program that creates animated presentations from XML. In versions 0.0.4 and below, Node.js automatically imports **/*.plugin.{js,mjs} files including those from node_modules, so any malicious package with a .plugin.js file can execute arbitrary code when installed or required. All projects using this loading behavior are affected, especially those installing untrusted packages. This issue has been fixed in version 0.0.5. To workaround this issue, users can audit and restrict which packages are installed in node_modules.
Affected products
- Tygo-van-den-Hurk Slyde: before 0.0.5 — fixed in 0.0.5
How to fix
Upgrade to a fixed version: Tygo-van-den-Hurk Slyde 0.0.5. Check the vendor advisory for mitigations.
References
- https://github.com/Tygo-van-den-Hurk/Slyde/commit/e4c215b061e44fd2ead805de34d72642a710af60
- https://github.com/Tygo-van-den-Hurk/Slyde/releases/tag/v0.0.5
- https://github.com/Tygo-van-den-Hurk/Slyde/security/advisories/GHSA-w7h5-55jg-cq2f
Get alerted when CVE-2026-26974 or the next vulnerability affects your stack