What’s Vulnerable › Vulnerabilities
CVE-2026-26979: Discourse: TL4 users are able to change status of restricted topics
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-26 · updated 2026-06-17
- Weakness: CWE-862
Description
Discourse is an open source discussion platform. Prior to versions 2025.12.2, 2026.1.1, and 2026.2.0, TL4 users are able to close, archive and pin topics in private categories they don't have access to. Versions 2025.12.2, 2026.1.1, and 2026.2.0 patch the issue. No known workarounds are available.
Affected products
- discourse: before 2025.12.0; from 2026.1.0 before 2026.1.1; 2026.2.0 — fixed in 2025.12.0, 2026.1.1
How to fix
Upgrade to a fixed version: discourse 2025.12.0, 2026.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-26979 or the next vulnerability affects your stack