What’s Vulnerable › Vulnerabilities
CVE-2026-26987: LibreNMS affected by reflected XSS via email field
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-20 · updated 2026-06-17
- Weakness: CWE-79
Description
LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Versions 25.12.0 and below are vulnerable to Reflected XSS attacks via email field. This issue has been fixed in version 26.2.0.
Affected products
- librenms: before 26.2.0 — fixed in 26.2.0
How to fix
Upgrade to a fixed version: librenms 26.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/8e626b38ef92e240532cdac2ac7e38706a71208b
- https://github.com/librenms/librenms/pull/19038
- https://github.com/librenms/librenms/releases/tag/26.2.0
- https://github.com/librenms/librenms/security/advisories/GHSA-gqx7-99jw-6fpr
Get alerted when CVE-2026-26987 or the next vulnerability affects your stack