What’s Vulnerable › Vulnerabilities
CVE-2026-27021: Discourse: Poll voters endpoint lacked post visibility checks
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-26 · updated 2026-06-17
- Weakness: CWE-862
Description
Discourse is an open source discussion platform. Prior to versions 2025.12.2, 2026.1.1, and 2026.2.0, the voters endpoint in the poll plugin lacked post visibility checks which allowed unauthorized access to voters details of polls in any post. Versions 2025.12.2, 2026.1.1, and 2026.2.0 patch the issue. No known workarounds are available.
Affected products
- discourse: before 2025.12.0; from 2026.1.0 before 2026.1.1; 2026.2.0 — fixed in 2025.12.0, 2026.1.1
How to fix
Upgrade to a fixed version: discourse 2025.12.0, 2026.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-27021 or the next vulnerability affects your stack