What’s Vulnerable › Vulnerabilities
CVE-2026-27121: Svelte affected by cross-site scripting via spread attributes in Svelte SSR
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-20 · updated 2026-06-17
- Weakness: CWE-79
Description
svelte performance oriented web framework. Versions of svelte prior to 5.51.5 are vulnerable to cross-site scripting (XSS) during server-side rendering. When using spread syntax to render attributes from untrusted data, event handler properties are included in the rendered HTML output. If an application spreads user-controlled or external data as element attributes, an attacker can inject malicious event handlers that execute in victims' browsers. This vulnerability is fixed in 5.51.5.
Affected products
- sveltejs svelte: before 5.51.5 — fixed in 5.51.5
How to fix
Upgrade to a fixed version: sveltejs svelte 5.51.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-27121 or the next vulnerability affects your stack