What’s Vulnerable › Vulnerabilities
CVE-2026-27126: Craft CMS has Stored XSS in Table Field via "HTML" Column Type
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-24 · updated 2026-06-17
- Weakness: CWE-79
Description
Craft is a content management system (CMS). In versions 4.5.0-RC1 through 4.16.18 and 5.0.0-RC1 through 5.8.22, a stored Cross-site Scripting (XSS) vulnerability exists in the `editableTable.twig` component when using the `html` column type. The application fails to sanitize the input, allowing an attacker to execute arbitrary JavaScript when another user views a page with the malicious table field. In order to exploit the vulnerability, an attacker must have an administrator account, and `allowAdminChanges` must be enabled in production, which is against Craft's security recommendations. Versions 4.16.19 and 5.8.23 patch the issue.
Affected products
- craftcms cms: from 4.5.0 (excl.) before 4.16.19; from 5.0.0 (excl.) before 5.8.23; 4.5.0, 4.5.0-rc1, 5.0.0, 5.0.0-rc1 — fixed in 4.16.19, 5.8.23
How to fix
Upgrade to a fixed version: craftcms cms 4.16.19, 5.8.23. Check the vendor advisory for mitigations.
References
- https://github.com/craftcms/cms/commit/f5d488d9bb6eff7670ed2c2fe30e15692e92c52b
- https://github.com/craftcms/cms/security/advisories/GHSA-3jh3-prx3-w6wc
Get alerted when CVE-2026-27126 or the next vulnerability affects your stack