What’s Vulnerable › Vulnerabilities

CVE-2026-27150: Discourse doesn't ensure guardian check when creating QueryGroupBookmark

Description

Discourse is an open source discussion platform. Prior to versions 2025.12.2, 2026.1.1, and 2026.2.0, missing `validate_before_create` authorization in Data Explorer's `QueryGroupBookmarkable` allows any logged-in user to create bookmarks for query groups they don't have access to, enabling metadata disclosure via bookmark reminder notifications. Versions 2025.12.2, 2026.1.1, and 2026.2.0 fix this issue and also make sure `validate_before_create` throws NotImplementedError in BaseBookmarkable if not implemented, to prevent similar issues in the future. No known workarounds are available.

Affected products

How to fix

Upgrade to a fixed version: discourse 2025.12.2, 2026.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-27150 or the next vulnerability affects your stack