What’s Vulnerable › Vulnerabilities
CVE-2026-27154: Discourse has XSS when editing a malicious post
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-26 · updated 2026-06-17
- Weakness: CWE-79
Description
Discourse is an open source discussion platform. Prior to versions 2025.12.2, 2026.1.1, and 2026.2.0, a user full name can be evaluated as raw HTML when the following settings are set: `display_name_on_posts` => true; and `prioritize_username_in_ux` => false. Editing a post of a malicious user would trigger an XSS. Versions 2025.12.2, 2026.1.1, and 2026.2.0 patch the issue. No known workarounds are available.
Affected products
- discourse: before 2025.12.2; from 2026.1.0 before 2026.1.1; 2026.2.0 — fixed in 2025.12.2, 2026.1.1
How to fix
Upgrade to a fixed version: discourse 2025.12.2, 2026.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-27154 or the next vulnerability affects your stack