What’s Vulnerable › Vulnerabilities
CVE-2026-27162: DIscourse doesn't prevent whispers to leak in excerpts
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-26 · updated 2026-06-17
- Weakness: CWE-200
Description
Discourse is an open source discussion platform. Prior to versions 2025.12.2, 2026.1.1, and 2026.2.0, `posts_nearby` was checking topic access but then returning all posts regardless of type, including whispers that should only be visible to whisperers. Use `Post.secured(guardian)` to properly filter post types based on user permissions. Versions 2025.12.2, 2026.1.1, and 2026.2.0 patch the issue. No known workarounds are available.
Affected products
- discourse: before 2025.12.2; from 2026.1.0 before 2026.1.1; 2026.2.0 — fixed in 2025.12.2, 2026.1.1
How to fix
Upgrade to a fixed version: discourse 2025.12.2, 2026.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-27162 or the next vulnerability affects your stack