What’s Vulnerable › Vulnerabilities

CVE-2026-27166: Discourse vulnerable to HTML injection via prohibited iframe URLs

Description

Discourse is an open source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1 and 2026.1.2, insufficient cleanup in the default Codepen allowed iframes value allows an attacker to trick a user into changing the URL of the main page. This issue has been fixed in versions 2026.3.0-latest.1, 2026.2.1 and 2026.1.2. To workaround this issue, remove Codepen from the list of allowed iframes.

Affected products

How to fix

Upgrade to a fixed version: discourse 2026.1.2, 2026.2.1, 2026.3.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-27166 or the next vulnerability affects your stack