What’s Vulnerable › Vulnerabilities
CVE-2026-27169: OpenSift: Persistent XSS Chat Tool Rendering
- Severity: high (CVSS 8.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-21 · updated 2026-06-17
- Weakness: CWE-79
Description
OpenSift is an AI study tool that sifts through large datasets using semantic search and generative AI. Versions 1.1.2-alpha and below render untrusted user/model content in chat tool UI surfaces using unsafe HTML interpolation patterns, leading to XSS. Stored content can execute JavaScript when later viewed in authenticated sessions. An attacker who can influence stored study/quiz/flashcard content could trigger script execution in a victim’s browser, potentially performing actions as that user in the local app session. This issue has been fixed in version 1.1.3-alpha.
Affected products
- OpenSift: before 1.1.3 — fixed in 1.1.3
How to fix
Upgrade to a fixed version: OpenSift 1.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/OpenSift/OpenSift/releases/tag/v1.1.3-alpha
- https://github.com/OpenSift/OpenSift/security/advisories/GHSA-qrpx-7cmv-5gv5
Get alerted when CVE-2026-27169 or the next vulnerability affects your stack