What’s Vulnerable › Vulnerabilities
CVE-2026-27189: OpenSift: Race-prone local persistence could cause state corruption/loss
- Severity: medium (CVSS 5.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-21 · updated 2026-06-17
- Weakness: CWE-362
Description
OpenSift is an AI study tool that sifts through large datasets using semantic search and generative AI. Versions 1.1.2-alpha and below, use non-atomic and insufficiently synchronized local JSON persistence flows, potentially causing concurrent operations to lose updates or corrupt local state across sessions/study/quiz/flashcard/wellness/auth stores. This issue has been fixed in version 1.1.3-alpha.
Affected products
- OpenSift: before 1.1.3 — fixed in 1.1.3
How to fix
Upgrade to a fixed version: OpenSift 1.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/OpenSift/OpenSift/releases/tag/v1.1.3-alpha
- https://github.com/OpenSift/OpenSift/security/advisories/GHSA-3pmp-j953-whxq
Get alerted when CVE-2026-27189 or the next vulnerability affects your stack