What’s Vulnerable › Vulnerabilities
CVE-2026-27196: Statamic affected by privilege escalation via stored Cross-site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Statmatic is a Laravel and Git powered content management system (CMS). Versions 5.73.8 and below in addition to 6.0.0-alpha.1 through 6.3.1 have a Stored XSS vulnerability in html fieldtypes which allows authenticated users with field management permissions to inject malicious JavaScript that executes when viewed by higher-privileged users. This issue has been fixed in 6.3.2 and 5.73.9.
Affected products
- Statamic: before 5.73.9; from 6.0.0 before 6.3.2 — fixed in 5.73.9, 6.3.2
How to fix
Upgrade to a fixed version: Statamic 5.73.9, 6.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/statamic/cms/commit/11ae40e62edd3da044d37ebf264757a09cc2347b
- https://github.com/statamic/cms/commit/6c270dacc2be02bfc2eee500766f3309f59d47b3
- https://github.com/statamic/cms/security/advisories/GHSA-8r7r-f4gm-wcpq
Get alerted when CVE-2026-27196 or the next vulnerability affects your stack