What’s Vulnerable › Vulnerabilities
CVE-2026-27197: Sentry: Improper Authentication on SAML SSO process allows user identity linking
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-21 · updated 2026-06-17
- Weakness: CWE-287
Description
Sentry is a developer-first error tracking and performance monitoring tool. Versions 21.12.0 through 26.1.0 have a critical vulnerability in its SAML SSO implementation which allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. Self-hosted users are only at risk if the following criteria is met: ore than one organizations are configured (SENTRY_SINGLE_ORGANIZATION = True), or malicious user has existing access and permissions to modify SSO settings for another organization in a multo-organization instance. This issue has been fixed in version 26.2.0. To workaround this issue, implement user account-based two-factor authentication to prevent an attacker from being able to complete authentication with a victim's user account. Organization administrators cannot do this on a user's behalf, this requires individual users to ensure 2FA has been enabled for their account.
Affected products
- getsentry sentry: from 21.12.0 before 26.2.0 — fixed in 26.2.0
How to fix
Upgrade to a fixed version: getsentry sentry 26.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-27197 or the next vulnerability affects your stack