What’s Vulnerable › Vulnerabilities

CVE-2026-2726: Incorrect Authorization in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 11.10 before 18.8.7, 18.9 before 18.9.3, and 18.10 before 18.10.1 that could have allowed an authenticated user to perform unauthorized actions on merge requests in other projects due to improper access control during cross-repository operations.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.8.7, 18.9.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-2726 or the next vulnerability affects your stack