What’s Vulnerable › Vulnerabilities

CVE-2026-27267: Illustrator | Stack-based Buffer Overflow (CWE-121)

Description

Illustrator versions 29.8.4, 30.1 and earlier are affected by a Stack-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Affected products

How to fix

Upgrade to a fixed version: Adobe Illustrator 29.8.5, 30.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-27267 or the next vulnerability affects your stack