What’s Vulnerable › Vulnerabilities
CVE-2026-2728
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-13 · updated 2026-06-17
- Weakness: CWE-79
Description
LibreNMS versions before 26.3.0 are affected by an authenticated Cross-site Scripting vulnerability on the showconfig page. Successful exploitation requires administrative privileges. Exploitation could result in XSS attacks being performed against other users with access to the page.
Affected products
- librenms: before 26.3.0 — fixed in 26.3.0
How to fix
Upgrade to a fixed version: librenms 26.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-2728 or the next vulnerability affects your stack