What’s Vulnerable › Vulnerabilities
CVE-2026-27314: Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-07 · updated 2026-10-26
- Weakness: CWE-267
Description
Privilege escalation in Apache Cassandra 5.0 on an mTLS environment using MutualTlsAuthenticator allows a user with only CREATE permission to associate their own certificate identity with an arbitrary role, including a superuser role, and authenticate as that role via ADD IDENTITY. Users are recommended to upgrade to version 5.0.7+, which fixes this issue.
Affected products
- Apache Software Foundation Apache Cassandra: from 5.0.0 before 5.0.7 — fixed in 5.0.7
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Cassandra 5.0.7. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/zrng82ddy4rpsmfyk582v6hqxcqrbz7f
- http://www.openwall.com/lists/oss-security/2026/04/07/7
Get alerted when CVE-2026-27314 or the next vulnerability affects your stack