What’s Vulnerable › Vulnerabilities
CVE-2026-27491: Discourse has a bypass of official warnings messages by non-staff users
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-19 · updated 2026-06-17
- Weakness: CWE-862
Description
Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, a type coercion issue in a post actions API endpoint allowed non-staff users to issue warnings to other users. Warnings are a staff-only moderation feature. The vulnerability required the attacker to be a logged-in user and to send a specifically crafted request. No data exposure or privilege escalation beyond the ability to create unauthorized user warnings was possible. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. No known workarounds are available.
Affected products
- discourse: from 2026.1.0 before 2026.1.2; from 2026.2.0 before 2026.2.1; 2026.3.0 — fixed in 2026.1.2, 2026.2.1
How to fix
Upgrade to a fixed version: discourse 2026.1.2, 2026.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/60a588f4da4ab0feceb2c44787d4261b4f8757be
- https://github.com/discourse/discourse/commit/d3cb203feabc46d765ecb91f348613a2bd531b89
- https://github.com/discourse/discourse/commit/f5fef73827da7520efc517357bd2a6bab35d7886
- https://github.com/discourse/discourse/security/advisories/GHSA-xq37-5fvf-4m4j
Get alerted when CVE-2026-27491 or the next vulnerability affects your stack