What’s Vulnerable › Vulnerabilities
CVE-2026-27497: n8n has Potential Remote Code Execution via Merge Node
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-25 · updated 2026-06-17
- Weakness: CWE-89
Description
n8n is an open source workflow automation platform. Prior to versions 2.10.1, 2.9.3, and 1.123.22, an authenticated user with permission to create or modify workflows could leverage the Merge node's SQL query mode to execute arbitrary code and write arbitrary files on the n8n server. The issues have been fixed in n8n versions 2.10.1, 2.9.3, and 1.123.22. Users should upgrade to one of these versions or later to remediate all known vulnerabilities. If upgrading is not immediately possible, administrators should consider the following temporary mitigations. Limit workflow creation and editing permissions to fully trusted users only, and/or disable the Merge node by adding `n8n-nodes-base.merge` to the `NODES_EXCLUDE` environment variable. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Affected products
- n8n-io n8n: before 1.123.22; from 2.0.0 before 2.9.3; from 2.10.0 before 2.10.1 — fixed in 1.123.22, 2.10.1, 2.9.3
How to fix
Upgrade to a fixed version: n8n-io n8n 1.123.22, 2.10.1, 2.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/releases/tag/n8n@1.123.22
- https://github.com/n8n-io/n8n/releases/tag/n8n@2.10.1
- https://github.com/n8n-io/n8n/releases/tag/n8n@2.9.3
- https://github.com/n8n-io/n8n/security/advisories/GHSA-wxx7-mcgf-j869
Get alerted when CVE-2026-27497 or the next vulnerability affects your stack