What’s Vulnerable › Vulnerabilities
CVE-2026-27572: Wasmtime can panic when adding excessive fields to a `wasi:http/types.fields` instance
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-24 · updated 2026-06-17
- Weakness: CWE-770
Description
Wasmtime is a runtime for WebAssembly. Prior to versions 24.0.6, 36.0.6, 4.0.04, 41.0.4, and 42.0.0, Wasmtime's implementation of the `wasi:http/types.fields` resource is susceptible to panics when too many fields are added to the set of headers. Wasmtime's implementation in the `wasmtime-wasi-http` crate is backed by a data structure which panics when it reaches excessive capacity and this condition was not handled gracefully in Wasmtime. Panicking in a WASI implementation is a Denial of Service vector for embedders and is treated as a security vulnerability in Wasmtime. Wasmtime 24.0.6, 36.0.6, 40.0.4, 41.0.4, and 42.0.0 patch this vulnerability and return a trap to the guest instead of panicking. There are no known workarounds at this time. Embedders are encouraged to update to a patched version of Wasmtime.
Affected products
- bytecodealliance wasmtime: before 24.0.6; from 25.0.0 before 36.0.6; from 37.0.0 before 40.0.4; from 41.0.0 before 41.0.4 — fixed in 24.0.6, 36.0.6, 40.0.4, 41.0.4
How to fix
Upgrade to a fixed version: bytecodealliance wasmtime 24.0.6, 36.0.6, 40.0.4, 41.0.4. Check the vendor advisory for mitigations.
References
- https://docs.rs/http/1.4.0/http/header/#limitations
- https://github.com/bytecodealliance/wasmtime/commit/301dc7162cca51def19131019af1187f45901c0a
- https://github.com/bytecodealliance/wasmtime/releases/tag/v24.0.6
- https://github.com/bytecodealliance/wasmtime/releases/tag/v36.0.6
- https://github.com/bytecodealliance/wasmtime/releases/tag/v40.0.4
- https://github.com/bytecodealliance/wasmtime/releases/tag/v41.0.4
- https://github.com/bytecodealliance/wasmtime/security/advisories/GHSA-243v-98vx-264h
Get alerted when CVE-2026-27572 or the next vulnerability affects your stack