What’s Vulnerable › Vulnerabilities
CVE-2026-27584: ActualBudget server is Missing Authentication for SimpleFIN and Pluggy AI bank sync endpoints
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-24 · updated 2026-06-17
- Weakness: CWE-306
Description
Actual is a local-first personal finance tool. Prior to version 26.2.1, missing authentication middleware in the ActualBudget server component allows any unauthenticated user to query the SimpleFIN and Pluggy.ai integration endpoints and read sensitive bank account balance and transaction information. This vulnerability allows an unauthenticated attacker to read the bank account balance and transaction history of ActualBudget users. This vulnerability impacts all ActualBudget Server users with the SimpleFIN or Pluggy.ai integrations configured. The ActualBudget Server instance must be reachable over the network. Version 26.2.1 patches the issue.
Affected products
- actualbudget actual: before 26.2.1 — fixed in 26.2.1
How to fix
Upgrade to a fixed version: actualbudget actual 26.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/actualbudget/actual/commit/ea937d100956ca56689ff852d99c28589e2a7d88
- https://github.com/actualbudget/actual/security/advisories/GHSA-m2cq-xjgm-f668
Get alerted when CVE-2026-27584 or the next vulnerability affects your stack