What’s Vulnerable › Vulnerabilities
CVE-2026-27589: Caddy vulnerable to cross-origin config application via local admin API /load (caddy)
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-24 · updated 2026-06-17
- Weakness: CWE-352
Description
Caddy is an extensible server platform that uses TLS by default. Prior to version 2.11.1, the local caddy admin API (default listen `127.0.0.1:2019`) exposes a state-changing `POST /load` endpoint that replaces the entire running configuration. When origin enforcement is not enabled (`enforce_origin` not configured), the admin endpoint accepts cross-origin requests (e.g., from attacker-controlled web content in a victim browser) and applies an attacker-supplied JSON config. This can change the admin listener settings and alter HTTP server behavior without user intent. Version 2.11.1 contains a fix for the issue.
Affected products
- caddyserver caddy: before 2.11.1 — fixed in 2.11.1
How to fix
Upgrade to a fixed version: caddyserver caddy 2.11.1. Check the vendor advisory for mitigations.
References
- https://github.com/caddyserver/caddy/releases/tag/v2.11.1
- https://github.com/caddyserver/caddy/security/advisories/GHSA-879p-475x-rqh2
- https://github.com/user-attachments/files/25079818/poc.zip
- https://github.com/user-attachments/files/25079820/PR_DESCRIPTION.md
Get alerted when CVE-2026-27589 or the next vulnerability affects your stack