What’s Vulnerable › Vulnerabilities
CVE-2026-27597: @enclave-vm/core is vulnerable to Sandbox Escape
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-25 · updated 2026-06-17
- Weakness: CWE-94
Description
Enclave is a secure JavaScript sandbox designed for safe AI agent code execution. Prior to version 2.11.1, it is possible to escape the security boundraries set by `@enclave-vm/core`, which can be used to achieve remote code execution (RCE). The issue has been fixed in version 2.11.1.
Affected products
- agentfront enclave: before 2.11.1 — fixed in 2.11.1
How to fix
Upgrade to a fixed version: agentfront enclave 2.11.1. Check the vendor advisory for mitigations.
References
- https://github.com/agentfront/enclave/commit/09afbebe4cb6d0586c1145aa71ffabd2103932db
- https://github.com/agentfront/enclave/security/advisories/GHSA-f229-3862-4942
Get alerted when CVE-2026-27597 or the next vulnerability affects your stack