What’s Vulnerable › Vulnerabilities
CVE-2026-27612: Repostat Vulnerable to Reflected Cross-Site Scripting (XSS) via repo prop in RepoCard
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-25 · updated 2026-06-17
- Weakness: CWE-79
Description
Repostat is a React component to fetch and display GitHub repository info. Prior to version 1.0.1, the `RepoCard` component is vulnerable to Reflected Cross-Site Scripting (XSS). The vulnerability occurs because the component uses React's `dangerouslySetInnerHTML` to render the repository name (`repo` prop) during the loading state without any sanitization. If a developer using this package passes unvalidated user input directly into the `repo` prop (for example, reading it from a URL query parameter), an attacker can execute arbitrary JavaScript in the context of the user's browser. In version 1.0.1, the use of dangerouslySetInnerHTML has been removed, and the repo prop is now safely rendered using standard React JSX data binding, which automatically escapes HTML entities.
Affected products
- denpiligrim repostat: before 1.0.1 — fixed in 1.0.1
How to fix
Upgrade to a fixed version: denpiligrim repostat 1.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/denpiligrim/repostat/commit/715df5f73359d222fd7876e948d14290180e3c88
- https://github.com/denpiligrim/repostat/security/advisories/GHSA-fm8c-6m29-rp6j
Get alerted when CVE-2026-27612 or the next vulnerability affects your stack